Reading Physician Assignment Issues

Incident Report for Omega AI

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 13:58 EDT

Identified

We have identified the cause of the current issue and our team is actively working on a fix. We will provide an update once a resolution has been deployed.

We apologize for any inconvenience and appreciate your patience.
Posted Mar 13, 2026 - 12:18 EDT

Update

We are continuing to investigate this issue.
Posted Mar 13, 2026 - 12:10 EDT

Investigating

We have had some reports about users being unable to assign reading physicians to studies. We are investigating and will provide an update on the findings
Posted Mar 13, 2026 - 12:02 EDT
This incident affected: Canada (www.omegaai.ca) (Worklist, Patient, Study and Order Management Services), USA (www.omegaai.com) (Worklist, Patient, Study and Order Management Services), and India (www.omegaai.in) (Worklist, Patient, Study and Order Management Services).