Intermittent Faxing Issues

Incident Report for Omega AI

Resolved

The issues have been resolved in the upstream fax provider.
Posted Apr 28, 2026 - 10:17 EDT

Identified

We're seeing slower-than-normal fax processing due to intermittent performance issues with our upstream fax provider. Faxes are still being sent and received, but some may take longer than usual to process.

We're monitoring the situation and will provide updates as it progresses.
Posted Apr 27, 2026 - 16:38 EDT
This incident affected: Canada (www.omegaai.ca) (Faxing), India (www.omegaai.in) (Faxing), and USA (www.omegaai.com) (Faxing).