Degraded services performance due to backend caching issues

Incident Report for Omega AI

Postmortem

We have identified and improved the inefficiencies in our ImagingStudy API, specifically related to how we handle the requests for large studies containing thousands of images. This improvement is expected to significantly reduce backend strain and improve overall system responsiveness.

Posted Jun 28, 2025 - 16:18 EDT

Resolved

On Jun 27, 2025 1:29pm EST, our backend services experience some brief delays due to slow performance of one of our Azure Redis Cache and API services. The platform healed up and recovered automatically at 1:53pm EST.

Our team is currently investigating the root cause and working on the improvement that we will share an update shortly

Login and Worklist services have been affected by this incident
Posted Jun 27, 2025 - 13:53 EDT