Unable to Create or Schedule Orders

Incident Report for Omega AI

Resolved

This issue has been resolved. Users were temporarily unable to create or schedule orders as a result of the earlier database issue affecting OmegaAI. Full functionality has been restored. If you continue to experience issues, please try refreshing your browser. For any further issues, please reach out to our support team.
Posted Jul 02, 2026 - 15:41 EDT

Investigating

We are currently investigating an issue preventing users from creating or scheduling orders. Our team is actively working on a resolution. We'll post updates here as we have more information. We apologize for the inconvenience.
Posted Jul 02, 2026 - 14:57 EDT
This incident affected: USA (www.omegaai.com) (Worklist, Scheduler).