This issue has been resolved. We identified a backend database issue affecting OmegaAI and Blume, which caused a service outage. The issue has been fixed and full functionality has been restored. If you continue to experience issues, please try refreshing your browser. For any further issues, please reach out to our support team.
Posted Jul 02, 2026 - 14:19 EDT
Monitoring
We're experiencing a service disruption. Our team is actively working on a resolution. We'll provide updates as soon as we have more information.
Posted Jul 02, 2026 - 14:13 EDT
This incident affected: USA (www.omegaai.com) (Login & Authentication Services, Worklist, Search, Organization Management Services, Document Viewer, Image Viewer, Workflow Automation, Blume Patient Portal, Scheduler, Voice to Text Service, AI Report Service, VNA Service, Root Business Analytics Service, Messaging, Faxing).